downgrade ядра ubuntu до версии 5.4

Для использования Active backup for business нужно ядро версии от 2.6 до 5.4. В моём случае имеем ядро 5.11.

ubuntu@hosting:~$ uname -a
Linux hosting 5.11.0-1019-oracle #20~20.04.1-Ubuntu SMP Tue Sep 21 14:18:09 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

даунгрейдим

sudo apt install linux-generic

и всё? 🤔

нет, теперь поменяем grub, чтобы грузилось ядро 5.4

sudo mcedit /etc/default/grub

комментируем #GRUB_DEFAULT=0
и добавляем GRUB_DEFAULT=«1>2»

обновляем Grub

sudo update-grub

и в ребут

sudo reboot

после перезагрузки снова проверим версию ядра

ubuntu@hosting:~$ uname -a
Linux hosting 5.4.0-89-generic #100-Ubuntu SMP Fri Sep 24 14:50:10 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

у нас всё получилось!

Поделиться
Отправить
Запинить
 41   9 мес   5.4   Downgrade kernel   ubuntu